Cannot install SharePoint – Specified value is not supported for the {0} parameter.

ADExplorer

I’ve been installing SharePoint foundation and I’ve run into strange error after installing all the prerequisites. When I got to the point that I ran the New-SPConfigurationDatabase I’ve encoutered this error:

New-SPConfigurationDatabase : Specified value is not supported for the {0} parameter.
At line:1 char:28
+ New-SPConfigurationDatabase <<<<  -DatabaseName SHP_Config -DatabaseServer SQL2012SPPS -AdministrationContentDatabaseName SHP_AdminContent
    + CategoryInfo          : InvalidData: (Microsoft.Share...urationDatabase:
   SPCmdletNewSPConfigurationDatabase) [New-SPConfigurationDatabase], ArgumentException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewSPConfigurationDatabase

After couple of hours of investigation where could the error be, after trying to check all the rights, .NET versions, I’ve finally tried to run the ADExplorer … I got the LOGONSERVER after running this simple command:

echo %LOGONSERVER%

When you run the ADExplorer (Downloadable from Microsoft site – HERE), you have to specify the logonserver, username and password. Username could be any user account from that domain, every account has read rights. After I inserted the correct data, I got this message:

ADExplorer

 

So the whole problem is … that even when it looks like that there is AD installed … it was not! It was LDAP that was looking exactly as the AD. But SharePoint cannot be installed without AD.

The end.

 

Leave a Reply


*